当前位置:首页 > 问答

通达信有顾比均线指标

我来帮TA回答

请哪个程序员大神帮忙在 集金号里面编辑 顾比均线指标,编辑好有感谢。做完后,直接截图给我就行

function F_XEMA()
{
close = CLOSE();
ma1 = EMA(close, 3);
DRAWLINE("EMA_1", ma1);
ma2 = EMA(close, 5);
DRAWLINE("EMA_2", ma2);
ma3 = EMA(close, 8);
DRAWLINE("EMA_3", ma3);
ma4 = EMA(close, 10);
DRAWLINE("EMA_4", ma4);
ma5 = EMA(close, 12);
DRAWLINE("EMA_5", ma5);
ma6 = EMA(close, 15);
DRAWLINE("EMA_6", ma6);
ma7 = EMA(close, 30);
DRAWLINE("EMA_6", ma7);
ma8 = EMA(close, 35);
DRAWLINE("EMA_6", ma8);
ma9 = EMA(close, 40);
DRAWLINE("EMA_6", ma9);
ma10 = EMA(close, 45);
DRAWLINE("EMA_6", ma10);
ma11 = EMA(close, 50);
DRAWLINE("EMA_6", ma11);
ma12 = EMA(close, 60);
DRAWLINE("EMA_6", ma12);
}
这个软件也没有公式编写帮助文件啊,只能拿系统再带的ema指标改一个,颜色不知道怎么写不会,将就用吧

顾比均线的通达信源码

E3:EMA(C,3),COLOR61DC16;
E5:EMA(C,5),COLOR61DC16;
E8:EMA(C,8),COLOR61DC16;
E10:EMA(C,10),COLOR61DC16;
E12:EMA(C,12),COLOR61DC16;
E15:EMA(C,15),COLOR61DC16;
E30:EMA(C,30),COLORD1875A;
E35:EMA(C,35),COLORD1875A;
E40:EMA(C,40),COLORD1875A;
E45:EMA(C,45),COLORD1875A;
E50:EMA(C,50),COLORD1875A;
E60:EMA(C,60),COLORD1875A;
IF(E3>REF(E3,1),E3,DRAWNULL),COLORYELLOW;
IF(E5>REF(E5,1),E5,DRAWNULL),COLORYELLOW;
IF(E8>REF(E8,1),E8,DRAWNULL),COLORYELLOW;
IF(E10>REF(E10,1),E10,DRAWNULL),COLORYELLOW;
IF(E12>REF(E12,1),E12,DRAWNULL),COLORYELLOW;
IF(E15>REF(E15,1),E15,DRAWNULL),COLORYELLOW;
IF(E30>REF(E30,1),E30,DRAWNULL),COLORFF00FF;
IF(E35>REF(E35,1),E35,DRAWNULL),COLORFF00FF;
IF(E40>REF(E40,1),E40,DRAWNULL),COLORFF00FF;
IF(E45>REF(E45,1),E45,DRAWNULL),COLORFF00FF;
IF(E50>REF(E50,1),E50,DRAWNULL),COLORFF00FF;
IF(E60>REF(E60,1),E60,DRAWNULL),COLORFF00FF;
STICKLINE(C>O,C,O,1,0),COLORRED;
STICKLINE(C>O,H,L,0,0),COLORRED;
STICKLINE(C<=O,C,O,1,0),COLORFFFF52;
STICKLINE(C<=O,H,L,0,0),COLORFFFF52;
DRAWICON(EMA(C,8)>EMA(C,15) AND EMA(C,40)>REF(EMA(C,40),1) AND CROSS(EMA(C,3),EMA(C,35)),L-0.20,24);
DRAWICON(EMA(C,15)>EMA(C,40) AND EMA(C,35)>REF(EMA(C,35),1) AND CROSS(EMA(C,3),EMA(C,5)),L-0.20,25);
DRAWICON(ABS(EMA(C,15)-EMA(C,60))/C<0.01 AND EMA(C,15)>EMA(C,30) AND O<EMA(C,3) AND C>EMA(C,3) AND O<EMA(C,15) AND C>EMA(C,15) AND O<EMA(C,30) AND C>EMA(C,30) AND O<EMA(C,60) AND C>EMA(C,60),L-0.20,27);
DRAWICON(ABS(EMA(C,45)-EMA(C,30))/C<0.011 AND EMA(C,3)>EMA(C,15) AND EMA(C,15)>EMA(C,40) AND CROSS(EMA(C,5),EMA(C,60)),L-0.20,13);
A1:=OPEN<EMA(C,20) OR OPEN<EMA(C,40) OR OPEN<EMA(C,60);
A2:=C>MAX(EMA(C,20),MAX(EMA(C,40),EMA(C,60)));
A3:=V/MA(V,10)>1.2;
A4:=C/REF(C,1)>1.049;
出水芙蓉:=A1 AND A2 AND A3 AND A4 AND O<EMA(C,60) AND C>EMA(C,60);
DRAWICON(出水芙蓉,L-0.20,9);

怎样在软件中找到顾比均线?

软件中不提供顾比均线公式。
需要自己新建公式
da:EMA(CLOSE,3),colorblue;
db:EMA(CLOSE,5) ,colorblue;
dc:EMA(CLOSE,8) ,colorblue;
dd:EMA(CLOSE,10) ,colorblue;
de:EMA(CLOSE,12) ,colorblue;
df:EMA(CLOSE,15) ,colorblue;
ca:EMA(CLOSE,30) ,coloryellow;
cb:EMA(CLOSE,35) ,coloryellow;
cc:EMA(CLOSE,40) ,coloryellow;
cd:EMA(CLOSE,45) ,coloryellow;
ce:EMA(CLOSE,50) ,coloryellow;
cf:EMA(CLOSE,60) ,coloryellow;
注:D开头的是短线组,C开头的是长线组,供参考。

股票中图形指标中的顾比均线是什么意思

该线是澳大利亚的投资家戴若-顾比发明,由两组均线组成,因此叫顾比线。正规叫法是顾比移动复合平均线,只要是能运用K线图的投资项目均能运用, 应用股票、期货和外汇交易中。
希望有帮助。

均线图基础知识:均线是什么意思

K线图是代表股价的走势的,但这里面的学问太深,真不是三言两语能够说明白的。只是给你简单说下吧。 K线图一般有五根线,分别是5日均线(白线),10日均线(黄线),20日均线(紫线),30日均线(绿线),60日均线(蓝线)。这里说的是同花顺炒股软件,不同的软件可能会有所区别,但大体相同。什么是5日均线?就是一只股票在最近五个交易日收盘时的平均价格。其它均线都是这样类推的。 什么样的K线图走势最理想?那就是五根线几乎呈平行线的姿态向右上方运行,那表明这只股票的股价最近一直是持续不断地向上攀升。但在实际情况中,几乎没有一只股票是这样的,只涨不跌,那这样的股票还不疯狂了?一般情况下,五条线有分有合,有时候密切连在一起,相当复杂。下图是600054黄山旅游放大了的K线图,5日均线翘头向上,远离10日均线,表明该股有发力向上突破的可能。你能看明白吗? K线图只是一个参考,记住了。如果炒股以它为目标,你可能有一半的时候是错误的。因为它有时呈现规律,有时不呈现规律。我们要综合各方面的情况来对一只股票进行分析研究。如成交量的变化,换手率,内外盘等。

股票k线图基础知识

5 10 20 60 120 250 设置这几条线 等这几条线走顺 买 大概率是挣钱的